Migrating plug-ins

This section describes how to migrate plug-ins to a v2.x devfile. A plug-in specified in a meta.yaml for a v1.x devfile no longer works in a v2.x devfile.

Additionally, v2.x devfiles include the following new features:

  • Parents allow users to reuse an existing devfile and partially replace plug-in functionality.

  • Eclipse Che IDEs and their tooling can be specified as attributes in a v2.x devfile or in a distinct YAML file, for example: .che/che-editor.yaml or .che/che-theia-plugin.yaml.

Additional resources

For more information on plug-ins in v2.x devfiles, go to the following GitHub issues: